Pardus Günlerim -2. /lib/libc.so.6: version `GLIBC_2.4′ not found (required by ./rar)

Pardus işletim sistemimiz ile kurcalama günlerine devam ediyorum. Şimdi garip bir hata ile karşılaştım. İnternetten The Mars Underground 2007 Filmini indirdim. Şifreli rar paketini tam 8 paketi açayım dedim.

Unrar e e5150-mars.part1.rar

Komutunu konsoldan verdim fakat karşıma unrar: /lib/libc.so.6: version `GLIBC_2.4′ not found (required by unrar)
hatasını çıkarttı. GlibC nin sürümünden kaynaklanan bir sorun olabilir diye düşünmeye başladım çünkü sistemimde GlibC yüklü yüklü olmasına rağmen bu hatayı aldım. hemen sistemime Winrar programını yükledim ffakat yine aynı hata karşıma çıktı.

unrar: /lib/libc.so.6: version `GLIBC_2.4′ not found (required by unrar) verdi.

Unrar veyahut rar çalışmıyor. Ayrıca PART1 üzerinde sağ tıklayıp aç dememe rağmen aynı hata ile karşılaşıyorum. Pisi’den depoda olan Glibc programını kontrol ettim bende yüklü gözüküyor.

Acaba paketi kaldırıp yeniden mi yüklesem ? derken aklıma geldi..

Konsolda Root login oldum.

su root

Şifre : ***********

Sonrada

sudo pisi bi http://svn.pardus.org.tr/pardus/devel/system/base/glibc/pspec.xml && pisi it glibc

Eğer Glibc ise sorun bu sayede Glibc nin paketini güncellemiş olacağız.

* Yama uygulanıyor: locale-no-archive.patch
* Yama uygulanıyor: glibc-2.5-ldconfig-old-cache.diff
* Yama uygulanıyor: glibc-2.4.90-no_NO.diff
açıldı (/var/pisi/glibc-2.6.1-23/work)
Kaynak yapılandırılıyor
Kaynak inşa ediliyor…

burada kaldık… Bekliyorum 5 dakkadır konsolda baka kaldım diyebilirim. Fakat hala kaynak inşa ediliyor diyor bekliyor…

Bu sorunun cevabını bulur bulmaz sizlerle paylaşacağım…

Bu sefer bana kolay gelsin 🙂

“Pardus Günlerim -2. /lib/libc.so.6: version `GLIBC_2.4′ not found (required by ./rar)” üzerine 2 yorum

  1. CTRL+C yapınca aşağıdaki hatayı da verdi mi?

    Traceback (most recent call last):
    File “error”, line 50, in build
    File “/usr/lib/pardus/pisi/actionsapi/autotools.py”, line 95, in make
    if system(‘make %s %s’ % (get.makeJOBS(), parameters)):
    File “/usr/lib/pardus/pisi/actionsapi/shelltools.py”, line 224, in system
    return run_logged(command)
    File “/usr/lib/pardus/pisi/util.py”, line 160, in run_logged
    out, err = p.communicate()
    File “/usr/lib/python2.4/subprocess.py”, line 1041, in communicate
    rlist, wlist, xlist = select.select(read_set, write_set, [])
    select.error: (4, ‘Interrupted system call’)

    Cevapla
  2. zet ;

    GLIBC_2.4′ olmadığı için bu hatayı veriyor. Glibc paketini güncelleyince sorun düzeliyor. Sorunu temelinde Partlar halinde paketlerin olmayı yatıyor. Sanırım Glibc kütüphanesi partları desteklemiyor. Yeni versiyonunda umarım bu sorun çözülür. Çünkü Part olmayan paketleri sistem açabiliyor.

    Cevapla

barış için bir cevap yazın Cevabı iptal et