Yum Update Hatası “qpid-cpp”

Centos 64 bit 6.2 kullanıyordum. Güncelleme çıkınca bir Update yapmak istedim. Ancak Centos üzerinde “Yum update” komutunu girdiğim zaman aşağıdaki hata ile karşılaştım..

[kirmizi] You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest [/kirmizi]

Yukarıdaki hata mesajını görünce “yum update –skip-broken” komutu ile güncellemeye devam etmek istedim. Ancak tekrar hata mesajı ile karşılaştım.

[sari]Packages skipped because of dependency problems:
qpid-cpp-client-0.14-22.el6_3.x86_64 from base
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64 from base
qpid-cpp-server-0.14-22.el6_3.x86_64 from base
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64 from base
qpid-qmf-0.14-14.el6_3.x86_64 from base[/sari]

Quid-cpp paketindeki bir sorun nedeni ile güncelleme yapmıyordu. Bu hatayı İnternet üzerinde araştırdığımda Centos’un 6.x sürümlerinde karşılaşanlar olduğunu gördüm.

Çözüm için ilk aklıma gelen paketi kaldırıp yeniden kurmak oldu…

Birinci Adım;

Öncelikle Quid-Cpp’yi kaldırıp yeniden kurmamız gerekiyor.

[mavi][[email protected] ~]# yum erase qpid-cpp-server[/mavi]

Komutunu girerek, Qpid-Cpp yazılımının Server paketini Yum ile Centos işletim sisteminden kaldırıyoruz.

Removed:
    qpid-cpp-server.x86_64 0:0.12-6.el6
Dependency Removed:
    matahari.x86_64 0:0.4.4-11.el6
    matahari-broker.x86_64 0:0.4.4-11.el6
    qpid-cpp-server-ssl.x86_64 0:0.12-6.el6

Complete!

Şeklinde kaldırdığını bize söyleyecektir.

İkinci adım;

İkinci adımda ise aşağıdaki komutu giriyoruz.

[mavi][[email protected] ~]# yum erase qpid-cpp-client[/mavi]

Bu komut ile Qpid-Cpp‘nin Client yazılımını kaldırmış oluyoruz.

Removed:
    qpid-cpp-client.x86_64 0:0.12-6.el6

Dependency Removed:
    matahari-agent-lib.x86_64 0:0.4.4-11.el6
    matahari-host.x86_64 0:0.4.4-11.el6
    matahari-network.x86_64 0:0.4.4-11.el6
    matahari-service.x86_64 0:0.4.4-11.el6
    matahari-sysconfig.x86_64 0:0.4.4-11.el6
    qpid-cpp-client-ssl.x86_64 0:0.12-6.el6
    qpid-qmf.x86_64 0:0.12-6.el6

Complete!

Client paketini ve Server paketini kaldırıldıktan sonra Quid-CPP‘yi yeniden kuruyoruz.

Üçüncü adım;

[mavi][[email protected] ~]# yum install qpid-cpp-server qpid-cpp-client[/mavi]


Komutunu girdiğimiz zaman Quid-Cpp paketinin Server ve Client versiyonları tekrardan kuruluyor. Kurulum bittiğinde ise “Complate” mesajını alacaksınız.

Güncellemeleri artık sorunsuz bir şekilde alabilirsiniz. Yum hata vermeyecek…

[mavi][[email protected] ~]# yum update[/mavi]

Komutunu girerek güncellemeleri alabilirsiniz. Hadi kolay gelsin…

Yorum yapın

teakolik hamza şamlıoğlu blog logo

Wordpress altyapısını kullandığımız bu sistem, Sunucu Çözümleri firmasında yüksek performans sağlayan özel sunucularda barındırılmaktadır. Görüntülemek için en iyi Chrome tarayıcı, 1920x1080 çözünürlük ve Full HD Android telefonlarda çalışır. Ayrıca Sitedeki içeriği istediğiniz gibi çarpabilirsiniz. :)